aboutsummaryrefslogtreecommitdiff
path: root/nix-personal/disk-config.nix
diff options
context:
space:
mode:
authorAria <me@aria.rip>2023-12-05 20:53:17 +0000
committerAria <me@aria.rip>2023-12-05 20:53:17 +0000
commit143c6f152e96214b4c75c31047a1eda0cd51513a (patch)
treed721752bac45d0993ef24aa7cfcccdd19aae1638 /nix-personal/disk-config.nix
parent318522a2613ec7242b2559be66b5edf466a2e5ef (diff)
own vps
Diffstat (limited to 'nix-personal/disk-config.nix')
-rw-r--r--nix-personal/disk-config.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/nix-personal/disk-config.nix b/nix-personal/disk-config.nix
new file mode 100644
index 0000000..5fb5fbc
--- /dev/null
+++ b/nix-personal/disk-config.nix
@@ -0,0 +1,48 @@
+# Example to create a bios compatible gpt partition
+{lib, ...}: {
+ disko.devices = {
+ disk.disk1 = {
+ device = lib.mkDefault "/dev/sda";
+ type = "disk";
+ content = {
+ type = "gpt";
+ partitions = {
+ boot = {
+ name = "boot";
+ size = "1M";
+ type = "EF02";
+ };
+ esp = {
+ name = "ESP";
+ size = "500M";
+ type = "EF00";
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ };
+ };
+ swap = {
+ name = "swap";
+ size = "2G";
+ content = {
+ type = "swap";
+ };
+ };
+ root = {
+ name = "root";
+ size = "100%";
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/";
+ mountOptions = [
+ "defaults"
+ ];
+ };
+ };
+ };
+ };
+ };
+ };
+}