aboutsummaryrefslogtreecommitdiff
path: root/nix-personal/disk-config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix-personal/disk-config.nix')
-rw-r--r--nix-personal/disk-config.nix48
1 files changed, 0 insertions, 48 deletions
diff --git a/nix-personal/disk-config.nix b/nix-personal/disk-config.nix
deleted file mode 100644
index 5fb5fbc..0000000
--- a/nix-personal/disk-config.nix
+++ /dev/null
@@ -1,48 +0,0 @@
-# Example to create a bios compatible gpt partition
-{lib, ...}: {
- disko.devices = {
- disk.disk1 = {
- device = lib.mkDefault "/dev/sda";
- type = "disk";
- content = {
- type = "gpt";
- partitions = {
- boot = {
- name = "boot";
- size = "1M";
- type = "EF02";
- };
- esp = {
- name = "ESP";
- size = "500M";
- type = "EF00";
- content = {
- type = "filesystem";
- format = "vfat";
- mountpoint = "/boot";
- };
- };
- swap = {
- name = "swap";
- size = "2G";
- content = {
- type = "swap";
- };
- };
- root = {
- name = "root";
- size = "100%";
- content = {
- type = "filesystem";
- format = "ext4";
- mountpoint = "/";
- mountOptions = [
- "defaults"
- ];
- };
- };
- };
- };
- };
- };
-}