aboutsummaryrefslogtreecommitdiff
path: root/examples/render-bsp/Cargo.toml
diff options
context:
space:
mode:
authortcmal <me@aria.rip>2024-08-25 17:44:21 +0100
committertcmal <me@aria.rip>2024-08-25 17:44:21 +0100
commit9f6b7a10e7e00edf6ab50a9cf162b377d84a43f6 (patch)
treefe4ebd024c59376c425073b4fa747fa70824d171 /examples/render-bsp/Cargo.toml
parent26c325640df7ab8b9ea4a6c3fd5166f7df7f80ff (diff)
feat(render) WIP: textures, using a fixed size texture array
currently using an 8 long texture array with seperate samplers. also move to a trait for resolving textures from the bsp file rather than adding them manually. currently stuck with one static implementation though. this means all textures in the file are loaded when the map is. not currently drawing with anything other than the first texture array, so files with >8 textures will fail.
Diffstat (limited to 'examples/render-bsp/Cargo.toml')
-rw-r--r--examples/render-bsp/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/examples/render-bsp/Cargo.toml b/examples/render-bsp/Cargo.toml
index 666f035..b8b5a9d 100644
--- a/examples/render-bsp/Cargo.toml
+++ b/examples/render-bsp/Cargo.toml
@@ -8,5 +8,6 @@ stockton-render = { path = "../../stockton-render", features = ["vulkan"] }
stockton-types = { path = "../../stockton-types" }
stockton-levels = { path = "../../stockton-levels" }
winit = "^0.21"
+log = "0.4.0"
simple_logger = "1.0"
image = "0.23.2"