aboutsummaryrefslogtreecommitdiff
path: root/examples/render-quad/Cargo.toml
diff options
context:
space:
mode:
authortcmal <me@aria.rip>2024-08-25 17:44:20 +0100
committertcmal <me@aria.rip>2024-08-25 17:44:20 +0100
commitb31035bf03e0843fb516bee065f9a010424ba546 (patch)
treeb98e55478f47da33e6f1faa994da6b91b97b9ad2 /examples/render-quad/Cargo.toml
parenta748e4c3e3615601ee2afe6d347ef439d8ff50fa (diff)
refactor(render): update gfx-hal and use staging and index buffers.
also some minor changes to types because of deprecation and a bunch of readability improvements
Diffstat (limited to 'examples/render-quad/Cargo.toml')
-rw-r--r--examples/render-quad/Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/examples/render-quad/Cargo.toml b/examples/render-quad/Cargo.toml
new file mode 100644
index 0000000..6f75543
--- /dev/null
+++ b/examples/render-quad/Cargo.toml
@@ -0,0 +1,14 @@
+[package]
+name = "render-triangles"
+version = "0.1.0"
+authors = ["Oscar <oscar.shrimpton.personal@gmail.com>"]
+
+[dependencies]
+stockton-render = { path = "../../stockton-render", features = ["vulkan"] }
+stockton-types = { path = "../../stockton-types" }
+stockton-bsp = "2.0.0"
+winit = "^0.21"
+log = "0.4.0"
+simple_logger = "1.0"
+rand = "0.7"
+