aboutsummaryrefslogtreecommitdiff
path: root/stockton-render/Cargo.toml
diff options
context:
space:
mode:
authortcmal <me@aria.rip>2024-08-25 17:44:22 +0100
committertcmal <me@aria.rip>2024-08-25 17:44:22 +0100
commite8126750633fd9ed3e682a2c889740a1f51a86f7 (patch)
treed2da548230f9ff3703fbf7f60f52f575f43d360d /stockton-render/Cargo.toml
parent6793abcd3bb054ff4c6dc0e6b97a76d463730deb (diff)
feat(render): rendy-memory for textures
unfortunately this involves downgrading gfx-hal
Diffstat (limited to 'stockton-render/Cargo.toml')
-rw-r--r--stockton-render/Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/stockton-render/Cargo.toml b/stockton-render/Cargo.toml
index 7c69be6..2840015 100644
--- a/stockton-render/Cargo.toml
+++ b/stockton-render/Cargo.toml
@@ -9,7 +9,7 @@ stockton-input = { path = "../stockton-input" }
stockton-levels = { path = "../stockton-levels" }
stockton-types = { path = "../stockton-types" }
winit = "^0.21"
-gfx-hal = "^0.5"
+gfx-hal = "0.4.1"
arrayvec = "0.4.10"
nalgebra-glm = "^0.6"
shaderc = "^0.7"
@@ -17,12 +17,13 @@ log = "0.4.0"
image = "0.23.11"
legion = { version = "^0.3" }
egui = "^0.2"
+rendy-memory = "0.5.2"
[features]
default = ["vulkan"]
vulkan = ["gfx-backend-vulkan"]
[dependencies.gfx-backend-vulkan]
-version = "^0.5"
+version = "0.4.1"
features = ["x11"]
optional = true