diff options
author | Rok Garbas <rok@garbas.si> | 2021-11-23 11:31:05 +0100 |
---|---|---|
committer | Rok Garbas <rok@garbas.si> | 2021-11-23 11:35:05 +0100 |
commit | cd72a8c346ca752441327cce4a2e94a2b38055bd (patch) | |
tree | 5c113b883eb4e029102c77ebc5f68a2c19731ce6 /flake.nix | |
parent | dbfcaa607abf5a21631a72874dd48a5e6661327e (diff) |
Make docker image downloadable in Hydra UI
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 14 |
1 files changed, 11 insertions, 3 deletions
@@ -407,10 +407,18 @@ # docker image with Nix inside dockerImage = nixpkgs.lib.genAttrs linux64BitSystems (system: - import ./docker.nix { + let pkgs = nixpkgsFor.${system}; - tag = version; - }); + image = import ./docker.nix { inherit pkgs; tag = version; }; + in pkgs.runCommand "docker-image-tarball-${version}" + { meta.description = "Docker image with Nix for ${system}"; + } + '' + mkdir -p $out/nix-support + image=$out/image.tar.gz + cp ${image} $image + echo "file binary-dist $image" >> $out/nix-support/hydra-build-products + ''); # Line coverage analysis. coverage = |