diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 14 |
1 files changed, 11 insertions, 3 deletions
@@ -407,10 +407,18 @@ # docker image with Nix inside dockerImage = nixpkgs.lib.genAttrs linux64BitSystems (system: - import ./docker.nix { + let pkgs = nixpkgsFor.${system}; - tag = version; - }); + image = import ./docker.nix { inherit pkgs; tag = version; }; + in pkgs.runCommand "docker-image-tarball-${version}" + { meta.description = "Docker image with Nix for ${system}"; + } + '' + mkdir -p $out/nix-support + image=$out/image.tar.gz + cp ${image} $image + echo "file binary-dist $image" >> $out/nix-support/hydra-build-products + ''); # Line coverage analysis. coverage = |