aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2021-09-14 12:22:28 +0200
committerGitHub <noreply@github.com>2021-09-14 12:22:28 +0200
commite664270c2b8fd79ddfe0ab8c7f15a730728ed623 (patch)
tree1ff0235245c3e3971b29f9ffffb6d622d728f7c7 /flake.nix
parenta4ae601b44be6c0ca44e24047f83bf4e0323d82e (diff)
parent2cf8110f5a01901a6d5394d62313e8b8a3a10b7e (diff)
Merge pull request #5246 from edolstra/faster-check
Speed up 'nix flake check'
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index 297d66134..9b737b850 100644
--- a/flake.nix
+++ b/flake.nix
@@ -178,8 +178,8 @@
installPhase = ''
mkdir -p $out
'';
- installCheckPhase = "make installcheck";
+ installCheckPhase = "make installcheck -j$NIX_BUILD_CORES -l$NIX_BUILD_CORES";
};
binaryTarball = buildPackages: nix: pkgs: let
@@ -502,10 +502,7 @@
# `NIX_DAEMON_SOCKET_PATH` which is required for the tests to work
# againstLatestStable = testNixVersions pkgs pkgs.nix pkgs.nixStable;
} "touch $out";
- } // (if system == "x86_64-linux" then (builtins.listToAttrs (map (crossSystem: {
- name = "binaryTarball-${crossSystem}";
- value = self.hydraJobs.binaryTarballCross.${system}.${crossSystem};
- }) crossSystems)) else {}));
+ });
packages = forAllSystems (system: {
inherit (nixpkgsFor.${system}) nix;