aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index 297d66134..9b737b850 100644
--- a/flake.nix
+++ b/flake.nix
@@ -178,8 +178,8 @@
installPhase = ''
mkdir -p $out
'';
- installCheckPhase = "make installcheck";
+ installCheckPhase = "make installcheck -j$NIX_BUILD_CORES -l$NIX_BUILD_CORES";
};
binaryTarball = buildPackages: nix: pkgs: let
@@ -502,10 +502,7 @@
# `NIX_DAEMON_SOCKET_PATH` which is required for the tests to work
# againstLatestStable = testNixVersions pkgs pkgs.nix pkgs.nixStable;
} "touch $out";
- } // (if system == "x86_64-linux" then (builtins.listToAttrs (map (crossSystem: {
- name = "binaryTarball-${crossSystem}";
- value = self.hydraJobs.binaryTarballCross.${system}.${crossSystem};
- }) crossSystems)) else {}));
+ });
packages = forAllSystems (system: {
inherit (nixpkgsFor.${system}) nix;