aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLulu <lulu.berlin.2023@gmail.com>2024-10-08 20:05:28 +0200
committerLulu <lulu.berlin.2023@gmail.com>2024-10-08 20:05:28 +0200
commit4ea8c9d6436f421dfd63638efd1fd01296bccc3f (patch)
tree657dc9826d7169ec673a66892af70afa8a5b1a1b /meson.build
parent43e79f443469c55ef4d3a43ce1e455d6eafcd26c (diff)
Set c++ version to c++23
I followed @pennae's advice and moved the constructor definition of `AttrName` from the header file `nixexpr.hh` to `nixexpr.cc`. Change-Id: I733f56c25635b366b11ba332ccec38dd7444e793
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c7fe647ce..2cf86e985 100644
--- a/meson.build
+++ b/meson.build
@@ -50,7 +50,7 @@ project('lix', 'cpp', 'rust',
meson_version : '>=1.4.0',
version : run_command('bash', '-c', 'echo -n $(jq -r .version < ./version.json)$VERSION_SUFFIX', check : true).stdout().strip(),
default_options : [
- 'cpp_std=c++2a',
+ 'cpp_std=c++23',
'rust_std=2021',
'warning_level=2',
'debug=true',