aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-10-04 21:17:25 -0700
committerJade Lovelace <lix@jade.fyi>2024-10-09 14:47:39 -0700
commit4180b84a677c363ab9f5ce500f0e5fa822d6c133 (patch)
tree0a1c503fc46e0597e332dcf3cc68f0c9bfacbaf6 /package.nix
parent3caf3e1e08220b59dee1dfe81549b3a0739f8565 (diff)
testsuite: use xdist for parallel test running
This is capped at 12 because 3.7 seconds of startup is painful enough and 5.5 seconds with 24 was more annoying. Change-Id: I327db40fd98deaa5330cd9cf6de99fb07b2c1cb0
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/package.nix b/package.nix
index b0b933ece..2d485be93 100644
--- a/package.nix
+++ b/package.nix
@@ -245,6 +245,7 @@ stdenv.mkDerivation (finalAttrs: {
[
python3
python3.pkgs.pytest
+ python3.pkgs.pytest-xdist
meson
ninja
cmake
@@ -479,6 +480,7 @@ stdenv.mkDerivation (finalAttrs: {
# FIXME: these have to be added twice due to the nix shell using a
# wrapped python instead of build inputs for its python inputs
p.pytest
+ p.pytest-xdist
p.yapf
p.python-frontmatter