aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-10-15 15:47:00 -0700
committerJade Lovelace <lix@jade.fyi>2024-10-18 15:40:22 -0700
commitca55060ac651471fffc39aa6d845c7eede2b72a5 (patch)
treecf2dd4de8c5ec97e3dfdc5873f0904c136832157 /package.nix
parent77b6f6734f830058b2375cfc96b5e0fb482cc1c2 (diff)
packaging: use in-tree capnproto derivation
This is done because the one in nixpkgs has several problems and we don't want to conflict with them fixing those problems: - not building shared libs - not building debuginfo (more critical for us due to https://git.lix.systems/lix-project/lix/issues/549) - not setting the correct cmake build type - not setting the correct cxxflags to build the coroutine library - not building with clang (required for the coroutine library since gcc is known to miscompile coroutines *in kj*). CC: https://git.lix.systems/lix-project/lix/issues/551 Fixes: https://git.lix.systems/lix-project/lix/issues/550 Change-Id: Ia5b78dc1809963fdd1a8203b127a216cb575d751
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/package.nix b/package.nix
index 4bce7cb5e..39ecea714 100644
--- a/package.nix
+++ b/package.nix
@@ -16,7 +16,6 @@
bzip2,
callPackage,
capnproto-lix ? __forDefaults.capnproto-lix,
- capnproto,
cmake,
curl,
doxygen,
@@ -106,8 +105,9 @@
build-release-notes = callPackage ./maintainers/build-release-notes.nix { };
- # needs explicit c++20 to enable coroutine support
- capnproto-lix = capnproto.overrideAttrs { CXXFLAGS = "-std=c++20"; };
+ # needs derivation patching to add debuginfo and coroutine library support
+ # !! must build this with clang as it is affected by the gcc coroutine bugs
+ capnproto-lix = callPackage ./misc/capnproto.nix { inherit stdenv; };
},
}:
@@ -449,6 +449,7 @@ stdenv.mkDerivation (finalAttrs: {
editline-lix
build-release-notes
pegtl
+ capnproto-lix
;
# The collection of dependency logic for this derivation is complicated enough that