aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-fail-bad-string-interpolation-4.nix
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-03-08 05:06:09 +0100
committereldritch horrors <pennae@lix.systems>2024-03-09 00:05:41 -0700
commit609a8e0d94926cae460ed6f12f1f8a3d9f91246b (patch)
tree81a786aa9ca89c3953097778766ad9a3df9054b4 /tests/functional/lang/eval-fail-bad-string-interpolation-4.nix
parent2f7c3fa2516a386af6c556dedc2811edb8302ffc (diff)
Merge pull request #9754 from 9999years/print-value-when-coercion-fails
Print the value in `error: cannot coerce` messages (cherry picked from commit 5b7bfd2d6b89d7dd5f54c1ca6c8072358d31a84e) === test taken from 6e8d5983143ae576e3f4b1d2954a5267f2943a49; it was added previously (and not backported because its pr was a mostly-revert), but it's useful to have around. Change-Id: Icbd14b55e3610ce7b774667bf14b82e6dc717982
Diffstat (limited to 'tests/functional/lang/eval-fail-bad-string-interpolation-4.nix')
-rw-r--r--tests/functional/lang/eval-fail-bad-string-interpolation-4.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-fail-bad-string-interpolation-4.nix b/tests/functional/lang/eval-fail-bad-string-interpolation-4.nix
new file mode 100644
index 000000000..457b5f06a
--- /dev/null
+++ b/tests/functional/lang/eval-fail-bad-string-interpolation-4.nix
@@ -0,0 +1,9 @@
+let
+ # Basically a "billion laughs" attack, but toned down to simulated `pkgs`.
+ ha = x: y: { a = x y; b = x y; c = x y; d = x y; e = x y; f = x y; g = x y; h = x y; j = x y; };
+ has = ha (ha (ha (ha (x: x)))) "ha";
+ # A large structure that has already been evaluated.
+ pkgs = builtins.deepSeq has has;
+in
+# The error message should not be too long.
+''${pkgs}''