aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-fail-bad-string-interpolation-4.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-fail-bad-string-interpolation-4.nix')
-rw-r--r--tests/functional/lang/eval-fail-bad-string-interpolation-4.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/functional/lang/eval-fail-bad-string-interpolation-4.nix b/tests/functional/lang/eval-fail-bad-string-interpolation-4.nix
new file mode 100644
index 000000000..457b5f06a
--- /dev/null
+++ b/tests/functional/lang/eval-fail-bad-string-interpolation-4.nix
@@ -0,0 +1,9 @@
+let
+ # Basically a "billion laughs" attack, but toned down to simulated `pkgs`.
+ ha = x: y: { a = x y; b = x y; c = x y; d = x y; e = x y; f = x y; g = x y; h = x y; j = x y; };
+ has = ha (ha (ha (ha (x: x)))) "ha";
+ # A large structure that has already been evaluated.
+ pkgs = builtins.deepSeq has has;
+in
+# The error message should not be too long.
+''${pkgs}''