aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-attrs2.nix
diff options
context:
space:
mode:
authorpiegames <git@piegames.de>2024-08-18 17:28:04 +0200
committerpiegames <git@piegames.de>2024-08-21 06:55:52 +0000
commit0a8888d1c7220eddba40895a9c6c63d06edf4614 (patch)
treea2400fb5880129a0a82225038c59611ed8da90ff /tests/functional/lang/eval-okay-attrs2.nix
parent7210ed1b87410a0df597c0c4efe642bf82cc2b06 (diff)
treewide: Stop using ancient let syntax
Shows for how long these tests have not been touched by anyone … Change-Id: I3d0c1209a86283ddb012db4e7d45073264fdd0eb
Diffstat (limited to 'tests/functional/lang/eval-okay-attrs2.nix')
-rw-r--r--tests/functional/lang/eval-okay-attrs2.nix11
1 files changed, 6 insertions, 5 deletions
diff --git a/tests/functional/lang/eval-okay-attrs2.nix b/tests/functional/lang/eval-okay-attrs2.nix
index 9e06b83ac..925dc1859 100644
--- a/tests/functional/lang/eval-okay-attrs2.nix
+++ b/tests/functional/lang/eval-okay-attrs2.nix
@@ -1,10 +1,11 @@
-let {
+let
as = { x = 123; y = 456; } // { z = 789; } // { z = 987; };
A = "a";
Z = "z";
- body = if builtins.hasAttr A as
- then builtins.getAttr A as
- else assert builtins.hasAttr Z as; builtins.getAttr Z as;
-}
+in
+if builtins.hasAttr A as then
+ builtins.getAttr A as
+else
+ assert builtins.hasAttr Z as; builtins.getAttr Z as