aboutsummaryrefslogtreecommitdiff
path: root/tests/functional/lang/eval-okay-attrs2.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional/lang/eval-okay-attrs2.nix')
-rw-r--r--tests/functional/lang/eval-okay-attrs2.nix11
1 files changed, 6 insertions, 5 deletions
diff --git a/tests/functional/lang/eval-okay-attrs2.nix b/tests/functional/lang/eval-okay-attrs2.nix
index 9e06b83ac..925dc1859 100644
--- a/tests/functional/lang/eval-okay-attrs2.nix
+++ b/tests/functional/lang/eval-okay-attrs2.nix
@@ -1,10 +1,11 @@
-let {
+let
as = { x = 123; y = 456; } // { z = 789; } // { z = 987; };
A = "a";
Z = "z";
- body = if builtins.hasAttr A as
- then builtins.getAttr A as
- else assert builtins.hasAttr Z as; builtins.getAttr Z as;
-}
+in
+if builtins.hasAttr A as then
+ builtins.getAttr A as
+else
+ assert builtins.hasAttr Z as; builtins.getAttr Z as