aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index fca9f4ed3..c7fe647ce 100644
--- a/meson.build
+++ b/meson.build
@@ -52,8 +52,7 @@ project('lix', 'cpp', 'rust',
default_options : [
'cpp_std=c++2a',
'rust_std=2021',
- # TODO(Qyriad): increase the warning level
- 'warning_level=1',
+ 'warning_level=2',
'debug=true',
'optimization=2',
'errorlogs=true', # Please print logs for tests that fail
@@ -485,7 +484,7 @@ add_project_arguments(
# TODO(Qyriad): Yes this is how the autoconf+Make system did it.
# It would be nice for our headers to be idempotent instead.
'-include', 'config.h',
- '-Wsign-compare',
+ '-Wno-unused-parameter',
'-Wno-deprecated-declarations',
'-Wimplicit-fallthrough',
'-Werror=switch',