aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/package.nix b/package.nix
index ff862bf92..2d485be93 100644
--- a/package.nix
+++ b/package.nix
@@ -170,6 +170,7 @@ let
functionalTestFiles = fileset.unions [
./tests/functional
+ ./tests/functional2
./tests/unit
(fileset.fileFilter (f: lib.strings.hasPrefix "nix-profile" f.name) ./scripts)
];
@@ -243,6 +244,8 @@ stdenv.mkDerivation (finalAttrs: {
nativeBuildInputs =
[
python3
+ python3.pkgs.pytest
+ python3.pkgs.pytest-xdist
meson
ninja
cmake
@@ -474,6 +477,11 @@ stdenv.mkDerivation (finalAttrs: {
pythonPackages = (
p: [
+ # FIXME: these have to be added twice due to the nix shell using a
+ # wrapped python instead of build inputs for its python inputs
+ p.pytest
+ p.pytest-xdist
+
p.yapf
p.python-frontmatter
p.requests