aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorjade <lix@jade.fyi>2024-10-14 05:53:44 +0000
committerGerrit Code Review <gerrit@localhost>2024-10-14 05:53:44 +0000
commit326cbecb61d42ce73caa391cdcb21acb2581bf7c (patch)
treee9a69b68fccc6c39c6038e8b229233d97a4225c7 /package.nix
parenta322fcea4a3630853bb1e91f411da5d37a8b4523 (diff)
parent4180b84a677c363ab9f5ce500f0e5fa822d6c133 (diff)
Merge changes I327db40f,If762efce into main
* changes: testsuite: use xdist for parallel test running testsuite: add a functional2 test suite based on pytest
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/package.nix b/package.nix
index ff862bf92..2d485be93 100644
--- a/package.nix
+++ b/package.nix
@@ -170,6 +170,7 @@ let
functionalTestFiles = fileset.unions [
./tests/functional
+ ./tests/functional2
./tests/unit
(fileset.fileFilter (f: lib.strings.hasPrefix "nix-profile" f.name) ./scripts)
];
@@ -243,6 +244,8 @@ stdenv.mkDerivation (finalAttrs: {
nativeBuildInputs =
[
python3
+ python3.pkgs.pytest
+ python3.pkgs.pytest-xdist
meson
ninja
cmake
@@ -474,6 +477,11 @@ stdenv.mkDerivation (finalAttrs: {
pythonPackages = (
p: [
+ # FIXME: these have to be added twice due to the nix shell using a
+ # wrapped python instead of build inputs for its python inputs
+ p.pytest
+ p.pytest-xdist
+
p.yapf
p.python-frontmatter
p.requests