aboutsummaryrefslogtreecommitdiff
path: root/incria/Cargo.toml
diff options
context:
space:
mode:
authortcmal <tcmal>2023-06-17 14:21:15 +0000
committerAria <me@aria.rip>2023-10-01 17:31:30 +0100
commit3291ea405b60695a25703e713c7fc47dda602e8d (patch)
tree64a6e3d48c9ed1e7497d13b72f4979642a88637a /incria/Cargo.toml
parent4dae16cae8d76f73dea60f09042b0c4b6585408c (diff)
avoid deadlocks by no longer returning read guard
Diffstat (limited to 'incria/Cargo.toml')
-rw-r--r--incria/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/incria/Cargo.toml b/incria/Cargo.toml
index 2dbe28a..55e6cdf 100644
--- a/incria/Cargo.toml
+++ b/incria/Cargo.toml
@@ -4,6 +4,7 @@ version = "0.1.0"
edition = "2021"
[dependencies]
+blink-alloc = { version = "0.3.0", features = ["sync"] }
tokio = { version = "1.28.1", features = ["sync", "rt"] }
[dev-dependencies]
@@ -16,4 +17,4 @@ path = "benches/pascal.rs"
[[bench]]
name = "pascal"
-harness = false \ No newline at end of file
+harness = false