aboutsummaryrefslogtreecommitdiff
path: root/nix-personal/configuration.nix
diff options
context:
space:
mode:
authorAria <me@aria.rip>2023-12-06 19:04:14 +0000
committerAria <me@aria.rip>2023-12-06 19:04:14 +0000
commitae760a1f14dffca65d98f4daa9ce09e138fd2532 (patch)
tree44d3bd7e78e7e515105736d80ec2cff1af6d3cbf /nix-personal/configuration.nix
parent143c6f152e96214b4c75c31047a1eda0cd51513a (diff)
colmena for vps
Diffstat (limited to 'nix-personal/configuration.nix')
-rw-r--r--nix-personal/configuration.nix23
1 files changed, 16 insertions, 7 deletions
diff --git a/nix-personal/configuration.nix b/nix-personal/configuration.nix
index 1830725..1b958e2 100644
--- a/nix-personal/configuration.nix
+++ b/nix-personal/configuration.nix
@@ -10,22 +10,31 @@
(modulesPath + "/profiles/qemu-guest.nix")
./disk-config.nix
];
+
+ # Basic setup
+ system.stateVersion = "23.11";
+
boot.loader.grub = {
# no need to set devices, disko will add all devices that have a EF02 partition to the list already
# devices = [ ];
efiSupport = true;
efiInstallAsRemovable = true;
};
- services.openssh.enable = true;
- environment.systemPackages = map lib.lowPrio [
- pkgs.curl
- pkgs.gitMinimal
- ];
+ deployment = {
+ targetHost = "puppy.girlth.ing";
+ buildOnTarget = true;
+ };
+ # SSH Access
+ services.openssh.enable = true;
users.users.root.openssh.authorizedKeys.keys = [
- "sk-ssh-ed25519@openssh.com AAAAGnNrLXNzaC1lZDI1NTE5QG9wZW5zc2guY29tAAAAIPKawhXHIFl+j/YciUzfT6AkuhLJQ9hwFU8Jl07bC7XqAAAABHNzaDo= me@aria.rip"
+ "no-touch-required sk-ssh-ed25519@openssh.com AAAAGnNrLXNzaC1lZDI1NTE5QG9wZW5zc2guY29tAAAAIPpKjZfzPN1KxVskFRnmTTCwzyCtjwcXVZc4i1rNfl9oAAAABHNzaDo= me@aria.rip"
];
- system.stateVersion = "23.11";
+ # Networking setup
+ networking = {
+ hostName = "puppy";
+ domain = "girlth.ing";
+ };
}